Forum forum.napiprojekt.pl Strona Główna


 FAQFAQ  RegulaminRegulamin   SzukajSzukaj   GrupyGrupy   RejestracjaRejestracja 
 ProfilProfil   Zaloguj się, by sprawdzić wiadomościZaloguj się, by sprawdzić wiadomości   ZalogujZaloguj  

Brak polskich znaków w pobranych napisach?
Idź do strony Poprzedni  1, 2
 
Napisz nowy temat   Odpowiedz do tematu    Forum forum.napiprojekt.pl Strona Główna -> Błędy
Zobacz poprzedni temat :: Zobacz następny temat  
Autor Wiadomość
kangaroo94



Dołączył: 15 Sie 2012
Posty: 10

Podziękował: 3
Łącznie otrzymał 2 podziękowań w 1 postach

Skąd: Kraków Ostrzeżenia: 0/5

PostWysłany: Sro Lut 20, 2013 14:18    Temat postu: Odpowiedz z cytatem

Podpinam się bo mam podobny problem, choć nie ten sam.

Zrobiłam napisy do filmu "It's in the water" (ID filmu: 1ae12c477615963af557032ef5e91334) i wczoraj wrzuciłam je na serwer. Kiedy tworzyłam te napisy, sprawdzałam je na najczęściej używanym przeze mnie odtwarzaczu Best Player - polskie znaki wyświetlały się wtedy prawidłowo. Wrzuciłam napisy na serwer i ściągnęłam ja na próbę - polskie znaki w pliku wyświetlają się prawidłowo, ale w Best Playerze już nie, czyli w postaci tzw. krzaków. Co ciekawe, miałam na dysku stare napisy (przed wrzuceniem na serwer) i one w Best Playerze nadal wyświetlają się prawidłowo...

Na innych odtwarzaczach (Gom Player i Windows Media Player) wszystko wyświetla się jak należy.
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
Reklamiarz
Członek zespołu








Ostrzeżenia:

PostWysłany: Sro Lut 20, 2013 14:18    Temat postu: Klikając w reklamę wspierasz serwis



Powrót do góry
yagis
Członek Zespołu NapiProjekt



Dołączył: 16 Cze 2008
Posty: 499

Podziękował: 3
Łącznie otrzymał 42 podziękowań w 42 postach

Skąd: KRK Ostrzeżenia: 0/5

PostWysłany: Sro Lut 20, 2013 14:25    Temat postu: Odpowiedz z cytatem

Być może masz w ustawieniach pobieranych napisów ustawiony format UTF zamiast ANSI. Dlatego nawet jeśli wysłałaś napisy w innym kodowaniu program w locie zamienia w trakcie pobierania na kodowanie nie obsługiwane przez odtwarzacz. Zmień na ANSI i wtedy sprawdź czy działa.
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość Wyślij email
kangaroo94



Dołączył: 15 Sie 2012
Posty: 10

Podziękował: 3
Łącznie otrzymał 2 podziękowań w 1 postach

Skąd: Kraków Ostrzeżenia: 0/5

PostWysłany: Sro Lut 20, 2013 14:42    Temat postu: Odpowiedz z cytatem

Bingo. Miałam ustawiony UTF, zmiana na ANSI rozwiązała problem.
Dziękuję za pomoc.
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
rootsrat



Dołączył: 04 Sie 2012
Posty: 4

Podziękował: 0
Łącznie otrzymał 0 podziękowań w 0 postach

Ostrzeżenia: 0/5

PostWysłany: Nie Sie 23, 2015 17:23    Temat postu: Odpowiedz z cytatem

Witam. Mam dokładnie ten sam problem i nic nie działa... Windows 10 angielski z UK regional settings. Odtwarzacz VLC Player. Próbowałem chyba już wszystkich kombinacji kodowania napisów w ustawieniach NapiProjekt i VLC i nic nie działa - cały czas mam "krzaczki" zamiast polskich znaków...
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
redherring



Dołączył: 03 Mar 2015
Posty: 233

Podziękował: 1
Łącznie otrzymał 22 podziękowań w 21 postach

Ostrzeżenia: 0/5

PostWysłany: Nie Sie 23, 2015 18:46    Temat postu: Odpowiedz z cytatem

rootsrat napisał:
Witam. Mam dokładnie ten sam problem i nic nie działa... Windows 10 angielski z UK regional settings. Odtwarzacz VLC Player. Próbowałem chyba już wszystkich kombinacji kodowania napisów w ustawieniach NapiProjekt i VLC i nic nie działa - cały czas mam "krzaczki" zamiast polskich znaków...


Spróbuj zmienić ustawienia regionalne:
http://forum.napiprojekt.pl/viewtopic.php?t=12125
_________________
Be sure to check out the best hacking game ever: http://codelinkv2.net/.
Also visit us on the CLv2 forum: http://codelinkv2.net/forum/.


Ostatnio zmieniony przez redherring dnia Nie Lis 15, 2015 10:09, w całości zmieniany 2 razy
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość Wyślij email
rootsrat



Dołączył: 04 Sie 2012
Posty: 4

Podziękował: 0
Łącznie otrzymał 0 podziękowań w 0 postach

Ostrzeżenia: 0/5

PostWysłany: Nie Sie 30, 2015 18:29    Temat postu: Odpowiedz z cytatem

redherring napisał:
rootsrat napisał:
Witam. Mam dokładnie ten sam problem i nic nie działa... Windows 10 angielski z UK regional settings. Odtwarzacz VLC Player. Próbowałem chyba już wszystkich kombinacji kodowania napisów w ustawieniach NapiProjekt i VLC i nic nie działa - cały czas mam "krzaczki" zamiast polskich znaków...


Spróbuj zmienić ustawienia regionalne:
http://forum.napiprojekt.pl/viewtopic.php?t=12125


Już próbowałem. Zrobiłem jeszcze raz, dla pewności, ale bez skutku... No wszędzie mam polski poustawiany, tylko Windows angielski i niestety nie działa, dalej ściąga z krzaczkami, niezależnie od tego jakie kodowanie ustawię w opcjach Napi Projekt Sad
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
redherring



Dołączył: 03 Mar 2015
Posty: 233

Podziękował: 1
Łącznie otrzymał 22 podziękowań w 21 postach

Ostrzeżenia: 0/5

PostWysłany: Nie Sie 30, 2015 20:41    Temat postu: Odpowiedz z cytatem

rootsrat napisał:
redherring napisał:
rootsrat napisał:
Witam. Mam dokładnie ten sam problem i nic nie działa... Windows 10 angielski z UK regional settings. Odtwarzacz VLC Player. Próbowałem chyba już wszystkich kombinacji kodowania napisów w ustawieniach NapiProjekt i VLC i nic nie działa - cały czas mam "krzaczki" zamiast polskich znaków...


Spróbuj zmienić ustawienia regionalne:
http://forum.napiprojekt.pl/viewtopic.php?t=12125


Już próbowałem. Zrobiłem jeszcze raz, dla pewności, ale bez skutku... No wszędzie mam polski poustawiany, tylko Windows angielski i niestety nie działa, dalej ściąga z krzaczkami, niezależnie od tego jakie kodowanie ustawię w opcjach Napi Projekt :(


Spróbuj zainstalować spolszczenie. W ustawieniach regionalnych powinna być opcja pobrania i zainstalowania spolszczenia.

Poza tym te krzaczki są wyświetlane tylko w VLC czy również w innych odtwarzaczach, czy edytorach? Jeśli tylko tam, to może wystarczy zmienić czcionkę, bo może nie obsługiwać znaków diakrytycznych.
_________________
Be sure to check out the best hacking game ever: http://codelinkv2.net/.
Also visit us on the CLv2 forum: http://codelinkv2.net/forum/.


Ostatnio zmieniony przez redherring dnia Nie Lis 15, 2015 10:08, w całości zmieniany 1 raz
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość Wyślij email
rootsrat



Dołączył: 04 Sie 2012
Posty: 4

Podziękował: 0
Łącznie otrzymał 0 podziękowań w 0 postach

Ostrzeżenia: 0/5

PostWysłany: Nie Sie 30, 2015 22:36    Temat postu: Odpowiedz z cytatem

Sęk w tym, że ja chcę mieć os po angielsku.

Krzaczki wyświetlane są również w innych programach (oczywiście tylko dla plików pobieranych przez NP).
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
yagis
Członek Zespołu NapiProjekt



Dołączył: 16 Cze 2008
Posty: 499

Podziękował: 3
Łącznie otrzymał 42 podziękowań w 42 postach

Skąd: KRK Ostrzeżenia: 0/5

PostWysłany: Pon Sie 31, 2015 07:00    Temat postu: Odpowiedz z cytatem

Zmień w takim razie język na angielski (dla programów nieobsługujących unicode) zrestartuj komputer i ponownie ustaw na język polski i znowu zrestartuj. To musi zadziałać.
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość Wyślij email
rootsrat



Dołączył: 04 Sie 2012
Posty: 4

Podziękował: 0
Łącznie otrzymał 0 podziękowań w 0 postach

Ostrzeżenia: 0/5

PostWysłany: Pon Sie 31, 2015 12:50    Temat postu: Odpowiedz z cytatem

yagis napisał:
Zmień w takim razie język na angielski (dla programów nieobsługujących unicode) zrestartuj komputer i ponownie ustaw na język polski i znowu zrestartuj. To musi zadziałać.


Mr Yagis, jesteś geniuszem Smile

Najprostsze rozwiązania są zawsze najlepsze. Dzięki za pomoc, zadziałało!
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
Wyświetl posty z ostatnich:   
Napisz nowy temat   Odpowiedz do tematu    Forum forum.napiprojekt.pl Strona Główna -> Błędy Wszystkie czasy w strefie CET (Europa)
Idź do strony Poprzedni  1, 2
Strona 2 z 2

 
Skocz do:  
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach


RSS

Powered by phpBB © 2001, 2005 phpBB Group