Forum forum.napiprojekt.pl Strona Główna


 FAQFAQ  RegulaminRegulamin   SzukajSzukaj   GrupyGrupy   RejestracjaRejestracja 
 ProfilProfil   Zaloguj się, by sprawdzić wiadomościZaloguj się, by sprawdzić wiadomości   ZalogujZaloguj  

Problem z niektórymi napisami w formacie SRT

 
Napisz nowy temat   Odpowiedz do tematu    Forum forum.napiprojekt.pl Strona Główna -> Napisy - pomoc techniczna
Zobacz poprzedni temat :: Zobacz następny temat  
Autor Wiadomość
styczek123



Dołączył: 27 Lut 2015
Posty: 2

Podziękował: 1
Łącznie otrzymał 0 podziękowań w 0 postach

Ostrzeżenia: 0/5

PostWysłany: Pią Lut 27, 2015 10:54    Temat postu: Problem z niektórymi napisami w formacie SRT Odpowiedz z cytatem

Witam,
Mam problem z wyświetlaniem niektórych napisów na telewizorze. Zgodnie ze specyfikacją tv odtwarza napisy w formacie SRT( kodowanie UTF-8 ). Tak też mam ustawiony napiprojekt.

Jednak czasami pobrane napisy w tym formacie są zapisane np. w taki sposób:
1
00:00:10,500 --> 00:00:13,000
Elephant's Dream

2
00:00:15,000 --> 00:00:18,000
At the left we can see...

A czasami taki:
{4043}{4156}/Teren zabezpieczony.|/Nie znaleźliśmy go.
{4218}{4351}- Wong nie będzie zachwycony.|- Ja też nie jestem.

Pierwszy mój telewizor odtwarza, drugiego już nie... skąd wynika ta różnica i jak ustawić, żeby napiprojekt pobierał zawsze napisy w pierwszej postaci?
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
Reklamiarz
Członek zespołu








Ostrzeżenia:

PostWysłany: Pią Lut 27, 2015 10:54    Temat postu: Klikając w reklamę wspierasz serwis



Powrót do góry
criskrakow
Członek Zespołu NapiProjekt



Dołączył: 02 Gru 2008
Posty: 3287

Podziękował: 23
Łącznie otrzymał 130 podziękowań w 129 postach

Skąd: KRK Ostrzeżenia: 0/5

PostWysłany: Sob Lut 28, 2015 07:19    Temat postu: Odpowiedz z cytatem

Takie powinieneś mieć ustawienia:

_________________
JEŚLI CI POMOGŁEM - KLIKNIJ PRZYCISK PODZIĘKUJ.


Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość Wyślij email
styczek123



Dołączył: 27 Lut 2015
Posty: 2

Podziękował: 1
Łącznie otrzymał 0 podziękowań w 0 postach

Ostrzeżenia: 0/5

PostWysłany: Sob Lut 28, 2015 10:23    Temat postu: Odpowiedz z cytatem

Pomogło, dzięki Smile

Ustawiłem niepotrzebnie wszystkie opcje w polu "Pliki z napisami zapisuj z rozszerzeniem:" na SRT.

Względem tego co wkleiłeś zmieniłem tylko kodowanie na UTF - 8, bo przy ANSI nie odtwarza mi polskich znaków.
Powrót do góry
Ogląda profil użytkownika Wyślij prywatną wiadomość
Wyświetl posty z ostatnich:   
Napisz nowy temat   Odpowiedz do tematu    Forum forum.napiprojekt.pl Strona Główna -> Napisy - pomoc techniczna Wszystkie czasy w strefie CET (Europa)
Strona 1 z 1

 
Skocz do:  
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach


RSS

Powered by phpBB © 2001, 2005 phpBB Group